summaryrefslogtreecommitdiffstats
path: root/httpx-bin
diff options
context:
space:
mode:
Diffstat (limited to 'httpx-bin')
-rw-r--r--httpx-bin/.SRCINFO20
-rw-r--r--httpx-bin/.gitignore5
-rw-r--r--httpx-bin/PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/httpx-bin/.SRCINFO b/httpx-bin/.SRCINFO
new file mode 100644
index 0000000..ae199c0
--- /dev/null
+++ b/httpx-bin/.SRCINFO
@@ -0,0 +1,20 @@
1pkgbase = httpx-bin
2 pkgdesc = Fast and multi-purpose HTTP toolkit
3 pkgver = 1.2.9
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/httpx
6 arch = x86_64
7 arch = armv6h
8 arch = aarch64
9 license = MIT
10 provides = httpx
11 conflicts = httpx
12 options = !strip
13 source_x86_64 = httpx-1.2.9-x86_64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.2.9/httpx_1.2.9_linux_amd64.zip
14 sha256sums_x86_64 = eb9e0a4959ce3d67af17ba3763485bd9ef1822b8907f22cc8ed1405b4b99bf6a
15 source_armv6h = httpx-1.2.9-armv6.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.2.9/httpx_1.2.9_linux_armv6.zip
16 sha256sums_armv6h = 95a98413264b9f1bfc5317af9499e32ce414ba06a51b7980c3d9a16a3e9c8f82
17 source_aarch64 = httpx-1.2.9-aarch64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.2.9/httpx_1.2.9_linux_arm64.zip
18 sha256sums_aarch64 = c2c95ba3b662d52eca35c71d1e17113bf02a127aaa00a8df1a4950dc5de43927
19
20pkgname = httpx-bin
diff --git a/httpx-bin/.gitignore b/httpx-bin/.gitignore
new file mode 100644
index 0000000..623d0e7
--- /dev/null
+++ b/httpx-bin/.gitignore
@@ -0,0 +1,5 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
5
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD
new file mode 100644
index 0000000..ee92d6d
--- /dev/null
+++ b/httpx-bin/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4_pkgname='httpx'
5pkgname="${_pkgname}-bin"
6pkgver=1.2.9
7pkgrel=1
8pkgdesc='Fast and multi-purpose HTTP toolkit'
9arch=('x86_64' 'armv6h' 'aarch64')
10url='https://github.com/projectdiscovery/httpx'
11license=('MIT')
12provides=("${_pkgname}")
13conflicts=("${_pkgname}")
14options=('!strip')
15
16source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip")
17source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_armv6.zip")
18source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip")
19
20sha256sums_x86_64=('eb9e0a4959ce3d67af17ba3763485bd9ef1822b8907f22cc8ed1405b4b99bf6a')
21sha256sums_armv6h=('95a98413264b9f1bfc5317af9499e32ce414ba06a51b7980c3d9a16a3e9c8f82')
22sha256sums_aarch64=('c2c95ba3b662d52eca35c71d1e17113bf02a127aaa00a8df1a4950dc5de43927')
23
24package() {
25 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
26 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
27 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
28}