diff options
Diffstat (limited to 'httpx-bin')
-rw-r--r-- | httpx-bin/.SRCINFO | 21 | ||||
-rw-r--r-- | httpx-bin/.gitignore | 5 | ||||
-rw-r--r-- | httpx-bin/PKGBUILD | 29 | ||||
-rw-r--r-- | httpx-bin/httpx-bin.install | 9 |
4 files changed, 64 insertions, 0 deletions
diff --git a/httpx-bin/.SRCINFO b/httpx-bin/.SRCINFO new file mode 100644 index 0000000..b7988fc --- /dev/null +++ b/httpx-bin/.SRCINFO | |||
@@ -0,0 +1,21 @@ | |||
1 | pkgbase = httpx-bin | ||
2 | pkgdesc = Fast and multi-purpose HTTP toolkit | ||
3 | pkgver = 1.3.5 | ||
4 | pkgrel = 2 | ||
5 | url = https://github.com/projectdiscovery/httpx | ||
6 | install = httpx-bin.install | ||
7 | arch = x86_64 | ||
8 | arch = armv6h | ||
9 | arch = aarch64 | ||
10 | license = MIT | ||
11 | provides = httpx | ||
12 | conflicts = httpx | ||
13 | options = !strip | ||
14 | source_x86_64 = httpx-1.3.5-x86_64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.5/httpx_1.3.5_linux_amd64.zip | ||
15 | sha256sums_x86_64 = 91da5708c15ff0211755e1acb4de2eb4f1f522aec5ffeb4ecbda44e2b28f8402 | ||
16 | source_armv6h = httpx-1.3.5-armv6.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.5/httpx_1.3.5_linux_arm.zip | ||
17 | sha256sums_armv6h = e910b51e5dadcf7b4c296b2707e54fe23c0e40a989eacc335178ac418d1ad926 | ||
18 | source_aarch64 = httpx-1.3.5-aarch64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.5/httpx_1.3.5_linux_arm64.zip | ||
19 | sha256sums_aarch64 = afd98638e58f5e86a09d230592193959a88e4bb047330ff9d170469a8b7af767 | ||
20 | |||
21 | pkgname = httpx-bin | ||
diff --git a/httpx-bin/.gitignore b/httpx-bin/.gitignore new file mode 100644 index 0000000..623d0e7 --- /dev/null +++ b/httpx-bin/.gitignore | |||
@@ -0,0 +1,5 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
5 | |||
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD new file mode 100644 index 0000000..91d7b76 --- /dev/null +++ b/httpx-bin/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <[email protected]> | ||
3 | |||
4 | _pkgname='httpx' | ||
5 | pkgname="${_pkgname}-bin" | ||
6 | pkgver=1.3.5 | ||
7 | pkgrel=2 | ||
8 | pkgdesc='Fast and multi-purpose HTTP toolkit' | ||
9 | arch=('x86_64' 'armv6h' 'aarch64') | ||
10 | url='https://github.com/projectdiscovery/httpx' | ||
11 | license=('MIT') | ||
12 | provides=("${_pkgname}") | ||
13 | conflicts=("${_pkgname}") | ||
14 | options=('!strip') | ||
15 | install="${pkgname}.install" | ||
16 | |||
17 | source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip") | ||
18 | source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm.zip") | ||
19 | source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip") | ||
20 | |||
21 | sha256sums_x86_64=('91da5708c15ff0211755e1acb4de2eb4f1f522aec5ffeb4ecbda44e2b28f8402') | ||
22 | sha256sums_armv6h=('e910b51e5dadcf7b4c296b2707e54fe23c0e40a989eacc335178ac418d1ad926') | ||
23 | sha256sums_aarch64=('afd98638e58f5e86a09d230592193959a88e4bb047330ff9d170469a8b7af767') | ||
24 | |||
25 | package() { | ||
26 | install -Dvm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}-toolkit" | ||
27 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}" | ||
28 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" | ||
29 | } | ||
diff --git a/httpx-bin/httpx-bin.install b/httpx-bin/httpx-bin.install new file mode 100644 index 0000000..0a0a1ef --- /dev/null +++ b/httpx-bin/httpx-bin.install | |||
@@ -0,0 +1,9 @@ | |||
1 | post_upgrade() { | ||
2 | cat <<- 'EOF' | ||
3 | |||
4 | The httpx binary has been installed as httpx-toolkit | ||
5 | Please adjust your workflow accordingly | ||
6 | This has been done to prevent a name clash with: | ||
7 | https://archlinux.org/packages/extra/any/python-httpx/ | ||
8 | EOF | ||
9 | } | ||