diff options
Diffstat (limited to 'httpx-bin')
-rw-r--r-- | httpx-bin/.SRCINFO | 20 | ||||
-rw-r--r-- | httpx-bin/.gitignore | 5 | ||||
-rw-r--r-- | httpx-bin/PKGBUILD | 28 |
3 files changed, 53 insertions, 0 deletions
diff --git a/httpx-bin/.SRCINFO b/httpx-bin/.SRCINFO new file mode 100644 index 0000000..c52e023 --- /dev/null +++ b/httpx-bin/.SRCINFO | |||
@@ -0,0 +1,20 @@ | |||
1 | pkgbase = httpx-bin | ||
2 | pkgdesc = Fast and multi-purpose HTTP toolkit | ||
3 | pkgver = 1.3.4 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/projectdiscovery/httpx | ||
6 | arch = x86_64 | ||
7 | arch = armv6h | ||
8 | arch = aarch64 | ||
9 | license = MIT | ||
10 | provides = httpx | ||
11 | conflicts = httpx | ||
12 | options = !strip | ||
13 | source_x86_64 = httpx-1.3.4-x86_64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.4/httpx_1.3.4_linux_amd64.zip | ||
14 | sha256sums_x86_64 = 5560e5da12fd66d4215981d9f73c3e10bfd0180d3b3440133e76c2a7bb95a891 | ||
15 | source_armv6h = httpx-1.3.4-armv6.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.4/httpx_1.3.4_linux_arm.zip | ||
16 | sha256sums_armv6h = 864ea3a135661bb6e7092f40d97a66784d8877ae76237116f2fae7f2dd45b7e5 | ||
17 | source_aarch64 = httpx-1.3.4-aarch64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.3.4/httpx_1.3.4_linux_arm64.zip | ||
18 | sha256sums_aarch64 = eb597578de681babd72f219a296b85cd6bc7e5bf9cafa4c24e9cc77947540058 | ||
19 | |||
20 | pkgname = httpx-bin | ||
diff --git a/httpx-bin/.gitignore b/httpx-bin/.gitignore new file mode 100644 index 0000000..623d0e7 --- /dev/null +++ b/httpx-bin/.gitignore | |||
@@ -0,0 +1,5 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
5 | |||
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD new file mode 100644 index 0000000..4d34433 --- /dev/null +++ b/httpx-bin/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | _pkgname='httpx' | ||
5 | pkgname="${_pkgname}-bin" | ||
6 | pkgver=1.3.4 | ||
7 | pkgrel=1 | ||
8 | pkgdesc='Fast and multi-purpose HTTP toolkit' | ||
9 | arch=('x86_64' 'armv6h' 'aarch64') | ||
10 | url='https://github.com/projectdiscovery/httpx' | ||
11 | license=('MIT') | ||
12 | provides=("${_pkgname}") | ||
13 | conflicts=("${_pkgname}") | ||
14 | options=('!strip') | ||
15 | |||
16 | source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip") | ||
17 | source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm.zip") | ||
18 | source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip") | ||
19 | |||
20 | sha256sums_x86_64=('5560e5da12fd66d4215981d9f73c3e10bfd0180d3b3440133e76c2a7bb95a891') | ||
21 | sha256sums_armv6h=('864ea3a135661bb6e7092f40d97a66784d8877ae76237116f2fae7f2dd45b7e5') | ||
22 | sha256sums_aarch64=('eb597578de681babd72f219a296b85cd6bc7e5bf9cafa4c24e9cc77947540058') | ||
23 | |||
24 | package() { | ||
25 | install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin" | ||
26 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}" | ||
27 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" | ||
28 | } | ||