diff options
Diffstat (limited to 'htpdate')
-rw-r--r-- | htpdate/.SRCINFO | 15 | ||||
-rw-r--r-- | htpdate/.gitignore | 4 | ||||
-rw-r--r-- | htpdate/PKGBUILD | 29 | ||||
-rw-r--r-- | htpdate/htpdate.service | 11 |
4 files changed, 59 insertions, 0 deletions
diff --git a/htpdate/.SRCINFO b/htpdate/.SRCINFO new file mode 100644 index 0000000..d8658a7 --- /dev/null +++ b/htpdate/.SRCINFO | |||
@@ -0,0 +1,15 @@ | |||
1 | pkgbase = htpdate | ||
2 | pkgdesc = HTTP Time protocol | ||
3 | pkgver = 1.3.7 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/twekkel/htpdate | ||
6 | arch = i686 | ||
7 | arch = x86_64 | ||
8 | license = GPL2 | ||
9 | depends = glibc | ||
10 | source = htpdate-1.3.7.tar.gz::https://github.com/twekkel/htpdate/archive/v1.3.7.tar.gz | ||
11 | source = htpdate.service | ||
12 | sha256sums = 88c52fe475308ee95f560fd7cf68c75bc6e9a6abf56be7fed203a7f762fe7ab2 | ||
13 | sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b | ||
14 | |||
15 | pkgname = htpdate | ||
diff --git a/htpdate/.gitignore b/htpdate/.gitignore new file mode 100644 index 0000000..aece887 --- /dev/null +++ b/htpdate/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | /update | ||
2 | /htpdate-*.tar.* | ||
3 | /pkg/ | ||
4 | /src/ | ||
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD new file mode 100644 index 0000000..0117c41 --- /dev/null +++ b/htpdate/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com> | ||
3 | # Contributor: Jonathan Ryan <jryan at curious-computing dot com> | ||
4 | # Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> | ||
5 | |||
6 | pkgname=htpdate | ||
7 | pkgver=1.3.7 | ||
8 | pkgrel=1 | ||
9 | pkgdesc="HTTP Time protocol" | ||
10 | arch=('i686' 'x86_64') | ||
11 | url="https://github.com/twekkel/htpdate" | ||
12 | license=(GPL2) | ||
13 | depends=('glibc') | ||
14 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" | ||
15 | "htpdate.service") | ||
16 | sha256sums=('88c52fe475308ee95f560fd7cf68c75bc6e9a6abf56be7fed203a7f762fe7ab2' | ||
17 | '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b') | ||
18 | |||
19 | build() { | ||
20 | cd ${pkgname}-${pkgver} | ||
21 | make | ||
22 | } | ||
23 | |||
24 | package() { | ||
25 | install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service | ||
26 | cd ${pkgname}-${pkgver} | ||
27 | install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate | ||
28 | install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 | ||
29 | } | ||
diff --git a/htpdate/htpdate.service b/htpdate/htpdate.service new file mode 100644 index 0000000..509b072 --- /dev/null +++ b/htpdate/htpdate.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Htpdate daemon | ||
3 | |||
4 | [Service] | ||
5 | Type=forking | ||
6 | PIDFile=/run/htpdate.pid | ||
7 | ExecStart=/usr/bin/htpdate -D -a -s -i /run/htpdate.pid www.linux.org www.freebsd.org ntp.neu.edu.cn www.kernel.org | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
11 | |||