summaryrefslogtreecommitdiffstats
path: root/gourmand
diff options
context:
space:
mode:
Diffstat (limited to 'gourmand')
-rw-r--r--gourmand/.SRCINFO33
-rw-r--r--gourmand/PKGBUILD35
2 files changed, 68 insertions, 0 deletions
diff --git a/gourmand/.SRCINFO b/gourmand/.SRCINFO
new file mode 100644
index 0000000..de3e92c
--- /dev/null
+++ b/gourmand/.SRCINFO
@@ -0,0 +1,33 @@
1pkgbase = gourmand
2 pkgdesc = A recipe manager for desktop that can import recipes
3 pkgver = 1.0.0
4 pkgrel = 4
5 url = https://github.com/GourmandRecipeManager/gourmand
6 arch = any
7 license = GPL
8 makedepends = python-pip
9 makedepends = gendesk
10 depends = python-gobject
11 depends = gtk3
12 depends = python-pyenchant
13 depends = gst-python
14 depends = python-pillow
15 depends = python-sqlalchemy1.3
16 depends = python-lxml
17 depends = python-cairo
18 depends = python-requests
19 optdepends = python-beautifulsoup4: Webpage import plugin
20 optdepends = python-scrape-schema-recipe: Webpage import plugin
21 optdepends = python-selenium
22 optdepends = python-keyring
23 optdepends = python-ebooklib: EPub export plugin
24 optdepends = python-reportlab: Printing & PDF export plugin
25 optdepends = python-gtkspellcheck: Spell checking plugin
26 optdepends = nuspell: Spell checking
27 optdepends = hspell: Spell checking for Hebrew
28 optdepends = libvoikko: Spell checking for Finnish language
29 conflicts = gourmet
30 source = gourmand-1.0.0-py3-none-any.whl::https://github.com/GourmandRecipeManager/gourmand/releases/download/1.0.0/gourmand-1.0.0-py3-none-any.whl
31 sha256sums = 9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4
32
33pkgname = gourmand
diff --git a/gourmand/PKGBUILD b/gourmand/PKGBUILD
new file mode 100644
index 0000000..610fd62
--- /dev/null
+++ b/gourmand/PKGBUILD
@@ -0,0 +1,35 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname='gourmand'
4pkgver=1.0.0
5pkgrel=4
6pkgdesc="A recipe manager for desktop that can import recipes"
7arch=('any')
8url="https://github.com/GourmandRecipeManager/gourmand"
9license=('GPL')
10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy1.3' 'python-lxml' 'python-cairo' 'python-requests')
11makedepends=('python-pip' 'gendesk')
12optdepends=(
13 'python-beautifulsoup4: Webpage import plugin'
14 'python-scrape-schema-recipe: Webpage import plugin'
15 'python-selenium'
16 'python-keyring'
17 'python-ebooklib: EPub export plugin'
18 'python-reportlab: Printing & PDF export plugin'
19 'python-gtkspellcheck: Spell checking plugin'
20 'nuspell: Spell checking'
21 'hspell: Spell checking for Hebrew'
22 'libvoikko: Spell checking for Finnish language'
23 )
24conflicts=('gourmet')
25source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
26sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
27
28prepare() {
29 gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
30}
31
32package() {
33 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
34 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
35}