diff options
Diffstat (limited to 'ghi')
-rw-r--r-- | ghi/.SRCINFO | 13 | ||||
-rw-r--r-- | ghi/PKGBUILD | 22 |
2 files changed, 35 insertions, 0 deletions
diff --git a/ghi/.SRCINFO b/ghi/.SRCINFO new file mode 100644 index 0000000..91be943 --- /dev/null +++ b/ghi/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = ghi | ||
2 | pkgdesc = GitHub Issues on the command line | ||
3 | pkgver = 1.2.1 | ||
4 | pkgrel = 2 | ||
5 | url = https://github.com/drazisil/ghi | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = git | ||
9 | depends = ruby | ||
10 | source = ghi-1.2.1.tar.gz::https://github.com/drazisil/ghi/archive/refs/tags/1.2.1.tar.gz | ||
11 | sha256sums = 83fbc4918ddf14df77ef06b28922f481747c6f4dc99b865e15d236b1db98c0b8 | ||
12 | |||
13 | pkgname = ghi | ||
diff --git a/ghi/PKGBUILD b/ghi/PKGBUILD new file mode 100644 index 0000000..99a99f7 --- /dev/null +++ b/ghi/PKGBUILD | |||
@@ -0,0 +1,22 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Eli Schwartz <eschwartz@archlinux.org> | ||
3 | # Contributor: Thomas Weißschuh <thomas t-8ch de> | ||
4 | |||
5 | pkgname=ghi | ||
6 | pkgver=1.2.1 | ||
7 | pkgrel=2 | ||
8 | pkgdesc='GitHub Issues on the command line' | ||
9 | arch=('any') | ||
10 | url="https://github.com/drazisil/${pkgname}" | ||
11 | license=('MIT') | ||
12 | depends=('ruby') | ||
13 | makedepends=('git') | ||
14 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz") | ||
15 | sha256sums=('83fbc4918ddf14df77ef06b28922f481747c6f4dc99b865e15d236b1db98c0b8') | ||
16 | |||
17 | package() { | ||
18 | cd "${srcdir}"/${pkgname}-${pkgver} | ||
19 | install -Dm755 -t "${pkgdir}"/usr/bin ghi | ||
20 | install -Dm644 -t "${pkgdir}"/usr/share/man/man1 man/ghi.1 | ||
21 | install -Dm644 -t "${pkgdir}"/usr/share/licenses/${pkgname} LICENSE | ||
22 | } | ||