diff options
Diffstat (limited to 'gau')
-rw-r--r-- | gau/.SRCINFO | 13 | ||||
-rw-r--r-- | gau/.gitignore | 4 | ||||
-rw-r--r-- | gau/PKGBUILD | 31 |
3 files changed, 48 insertions, 0 deletions
diff --git a/gau/.SRCINFO b/gau/.SRCINFO new file mode 100644 index 0000000..b764610 --- /dev/null +++ b/gau/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = gau | ||
2 | pkgdesc = Fetch known URLs from AlienVault's Open Threat Exchange, the Wayback Machine, and Common Crawl | ||
3 | pkgver = 2.2.3 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/lc/gau | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = go | ||
9 | depends = glibc | ||
10 | source = gau-2.2.3.tar.gz::https://github.com/lc/gau/archive/v2.2.3.tar.gz | ||
11 | sha256sums = 02bb84bd73a385b4630a6c783f819f8339defc915df3a7d34cb872801d567c17 | ||
12 | |||
13 | pkgname = gau | ||
diff --git a/gau/.gitignore b/gau/.gitignore new file mode 100644 index 0000000..05c6d4d --- /dev/null +++ b/gau/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
diff --git a/gau/PKGBUILD b/gau/PKGBUILD new file mode 100644 index 0000000..6276734 --- /dev/null +++ b/gau/PKGBUILD | |||
@@ -0,0 +1,31 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: <contact@amadejpapez.com> | ||
3 | |||
4 | pkgname=gau | ||
5 | pkgver=2.2.3 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Fetch known URLs from AlienVault's Open Threat Exchange, the Wayback Machine, and Common Crawl" | ||
8 | arch=(any) | ||
9 | url='https://github.com/lc/gau' | ||
10 | license=(MIT) | ||
11 | depends=(glibc) | ||
12 | makedepends=(go) | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
14 | sha256sums=('02bb84bd73a385b4630a6c783f819f8339defc915df3a7d34cb872801d567c17') | ||
15 | |||
16 | build() { | ||
17 | export CGO_CPPFLAGS="${CPPFLAGS}" | ||
18 | export CGO_CFLAGS="${CFLAGS}" | ||
19 | export CGO_CXXFLAGS="${CXXFLAGS}" | ||
20 | export CGO_LDFLAGS="${LDFLAGS}" | ||
21 | export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" | ||
22 | |||
23 | cd "${pkgname}-${pkgver}/cmd/gau" | ||
24 | go build -v -o "${pkgname}" . | ||
25 | } | ||
26 | |||
27 | package() { | ||
28 | cd "${pkgname}-${pkgver}" | ||
29 | install -Dvm755 "cmd/gau/gau" -t "${pkgdir}/usr/bin" | ||
30 | install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}" | ||
31 | } | ||