diff options
Diffstat (limited to 'flowy')
-rw-r--r-- | flowy/.SRCINFO | 13 | ||||
-rw-r--r-- | flowy/PKGBUILD | 30 |
2 files changed, 43 insertions, 0 deletions
diff --git a/flowy/.SRCINFO b/flowy/.SRCINFO new file mode 100644 index 0000000..a6a3064 --- /dev/null +++ b/flowy/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = flowy | ||
2 | pkgdesc = A lean, privacy-preserving dynamic wallpaper changer written in Rust | ||
3 | pkgver = 0.4.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/vineetred/flowy | ||
6 | arch = x86_64 | ||
7 | license = GPL | ||
8 | makedepends = cargo | ||
9 | conflicts = flowy-git | ||
10 | source = flowy-0.4.0.tar.gz::https://github.com/vineetred/flowy/archive/0.4.0.tar.gz | ||
11 | sha256sums = a0c4b98140df25f4c0a6d129dd9f5394c930c304c93527b5a7c664d649b9d677 | ||
12 | |||
13 | pkgname = flowy | ||
diff --git a/flowy/PKGBUILD b/flowy/PKGBUILD new file mode 100644 index 0000000..de48302 --- /dev/null +++ b/flowy/PKGBUILD | |||
@@ -0,0 +1,30 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=flowy | ||
4 | pkgver=0.4.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="A lean, privacy-preserving dynamic wallpaper changer written in Rust" | ||
7 | arch=('x86_64') | ||
8 | url="https://github.com/vineetred/flowy" | ||
9 | license=('GPL') | ||
10 | makedepends=('cargo') | ||
11 | conflicts=("${pkgname}-git") | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
13 | sha256sums=('a0c4b98140df25f4c0a6d129dd9f5394c930c304c93527b5a7c664d649b9d677') | ||
14 | |||
15 | prepare() { | ||
16 | cd "$pkgname-$pkgver" | ||
17 | cargo fetch --locked --target "$CARCH-unknown-linux-gnu" | ||
18 | } | ||
19 | |||
20 | build() { | ||
21 | cd "$pkgname-$pkgver" | ||
22 | export RUSTUP_TOOLCHAIN=stable | ||
23 | export CARGO_TARGET_DIR=target | ||
24 | cargo build --frozen --release --all-features | ||
25 | } | ||
26 | |||
27 | package() { | ||
28 | cd "$pkgname-$pkgver" | ||
29 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" | ||
30 | } | ||