aboutsummaryrefslogtreecommitdiffstats
path: root/euterpe/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'euterpe/PKGBUILD')
-rw-r--r--euterpe/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/euterpe/PKGBUILD b/euterpe/PKGBUILD
new file mode 100644
index 0000000..ef350ce
--- /dev/null
+++ b/euterpe/PKGBUILD
@@ -0,0 +1,34 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=euterpe
4pkgver=1.5.2
5pkgrel=1
6pkgdesc='Self-hosted music streaming server with RESTful API and Web interface'
7arch=('x86_64')
8url="https://github.com/ironsmile/$pkgname"
9license=('GPL')
10depends=('taglib' 'icu')
11makedepends=('go')
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
13sha256sums=('58757a006b2e99519017a2dbc44760a3100fb655fe220bfbed0144bf3b8ff427')
14
15prepare(){
16 cd "$pkgname-$pkgver"
17 mkdir -p build/
18}
19
20build() {
21 cd "$pkgname-$pkgver"
22 export CGO_CPPFLAGS="${CPPFLAGS}"
23 export CGO_CFLAGS="${CFLAGS}"
24 export CGO_CXXFLAGS="${CXXFLAGS}"
25 export CGO_LDFLAGS="${LDFLAGS}"
26 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
27
28 go build -o build
29}
30
31package() {
32 cd "$pkgname-$pkgver"
33 install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
34}