aboutsummaryrefslogtreecommitdiffstats
path: root/efm-langserver/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'efm-langserver/PKGBUILD')
-rw-r--r--efm-langserver/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/efm-langserver/PKGBUILD b/efm-langserver/PKGBUILD
new file mode 100644
index 0000000..68896d6
--- /dev/null
+++ b/efm-langserver/PKGBUILD
@@ -0,0 +1,36 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Daniel M. Capella <polyzen@archlinux.org>
3# Contributor: dianlujitao <dianlujitao at gmail dot com>
4
5pkgname=efm-langserver
6pkgver=0.0.44
7pkgrel=1
8pkgdesc='General purpose Language Server'
9arch=('x86_64')
10url=https://github.com/mattn/efm-langserver
11license=('MIT')
12depends=('glibc')
13makedepends=('go')
14optdepends=('ctags: for "go to definition" requests')
15source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
16sha256sums=('825aef5815fb6eff656370e9f01fc31f91e5b2ab9d2b1f080881839676020dac')
17
18build() {
19 cd $pkgname-$pkgver
20 export CGO_CPPFLAGS="$CPPFLAGS"
21 export CGO_CFLAGS="$CFLAGS"
22 export CGO_CXXFLAGS="$CXXFLAGS"
23 export CGO_LDFLAGS="$LDFLAGS"
24 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
25 go build .
26}
27
28check() {
29 cd $pkgname-$pkgver
30 go test -v ./...
31}
32
33package() {
34 cd $pkgname-$pkgver
35 install -Dt "$pkgdir"/usr/bin efm-langserver
36}