summaryrefslogtreecommitdiffstats
path: root/dnsx
diff options
context:
space:
mode:
Diffstat (limited to 'dnsx')
-rw-r--r--dnsx/.SRCINFO13
-rw-r--r--dnsx/.gitignore4
-rw-r--r--dnsx/PKGBUILD37
3 files changed, 54 insertions, 0 deletions
diff --git a/dnsx/.SRCINFO b/dnsx/.SRCINFO
new file mode 100644
index 0000000..51751d0
--- /dev/null
+++ b/dnsx/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = dnsx
2 pkgdesc = Fast and multi-purpose DNS toolkit
3 pkgver = 1.1.4
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/dnsx
6 arch = x86_64
7 license = MIT
8 makedepends = go
9 provides = dnsx
10 source = dnsx-1.1.4.tar.gz::https://github.com/projectdiscovery/dnsx/archive/v1.1.4.tar.gz
11 sha256sums = 7c0868cb27f904ab8e158881cf4862a15f216122a43525d2ea93a1aa7bf03cff
12
13pkgname = dnsx
diff --git a/dnsx/.gitignore b/dnsx/.gitignore
new file mode 100644
index 0000000..05c6d4d
--- /dev/null
+++ b/dnsx/.gitignore
@@ -0,0 +1,4 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/dnsx/PKGBUILD b/dnsx/PKGBUILD
new file mode 100644
index 0000000..2a7a968
--- /dev/null
+++ b/dnsx/PKGBUILD
@@ -0,0 +1,37 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='dnsx'
5pkgver=1.1.4
6pkgrel=1
7pkgdesc='Fast and multi-purpose DNS toolkit'
8arch=('x86_64')
9url='https://github.com/projectdiscovery/dnsx'
10license=('MIT')
11makedepends=('go')
12provides=("${pkgname}")
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14sha256sums=('7c0868cb27f904ab8e158881cf4862a15f216122a43525d2ea93a1aa7bf03cff')
15
16prepare() {
17 export GOPATH="${srcdir}/gopath"
18 go clean -modcache
19}
20
21build() {
22 export CGO_CPPFLAGS="${CPPFLAGS}"
23 export CGO_CFLAGS="${CFLAGS}"
24 export CGO_CXXFLAGS="${CXXFLAGS}"
25 export CGO_LDFLAGS="${LDFLAGS}"
26 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
27
28 cd "${pkgname}-${pkgver}/cmd/${pkgname}"
29 go build -v -o "${pkgname}" .
30}
31
32package() {
33 cd "${pkgname}-${pkgver}"
34 install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin"
35 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
36 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
37}