diff options
Diffstat (limited to 'dnsx/PKGBUILD')
-rw-r--r-- | dnsx/PKGBUILD | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/dnsx/PKGBUILD b/dnsx/PKGBUILD new file mode 100644 index 0000000..8e0e7d5 --- /dev/null +++ b/dnsx/PKGBUILD | |||
@@ -0,0 +1,37 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | pkgname='dnsx' | ||
5 | pkgver=1.2.1 | ||
6 | pkgrel=1 | ||
7 | pkgdesc='Fast and multi-purpose DNS toolkit' | ||
8 | arch=('x86_64') | ||
9 | url='https://github.com/projectdiscovery/dnsx' | ||
10 | license=('MIT') | ||
11 | makedepends=('go') | ||
12 | provides=("${pkgname}") | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
14 | sha256sums=('08a806e1f87e11e1a4953bf84a35c77afdd84a946b8e7c9b602443007eeb1fe3') | ||
15 | |||
16 | prepare() { | ||
17 | export GOPATH="${srcdir}/gopath" | ||
18 | go clean -modcache | ||
19 | } | ||
20 | |||
21 | build() { | ||
22 | export CGO_CPPFLAGS="${CPPFLAGS}" | ||
23 | export CGO_CFLAGS="${CFLAGS}" | ||
24 | export CGO_CXXFLAGS="${CXXFLAGS}" | ||
25 | export CGO_LDFLAGS="${LDFLAGS}" | ||
26 | export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" | ||
27 | |||
28 | cd "${pkgname}-${pkgver}/cmd/${pkgname}" | ||
29 | go build -v -o "${pkgname}" . | ||
30 | } | ||
31 | |||
32 | package() { | ||
33 | cd "${pkgname}-${pkgver}" | ||
34 | install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin" | ||
35 | install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}" | ||
36 | install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | ||
37 | } | ||