aboutsummaryrefslogtreecommitdiffstats
path: root/dnsx/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'dnsx/PKGBUILD')
-rw-r--r--dnsx/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/dnsx/PKGBUILD b/dnsx/PKGBUILD
new file mode 100644
index 0000000..5b61348
--- /dev/null
+++ b/dnsx/PKGBUILD
@@ -0,0 +1,37 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='dnsx'
5pkgver=1.1.1
6pkgrel=1
7pkgdesc='Fast and multi-purpose DNS toolkit'
8arch=('x86_64')
9url='https://github.com/projectdiscovery/dnsx'
10license=('MIT')
11makedepends=('go')
12provides=("${pkgname}")
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14sha256sums=('b136298b2139bf5a2c94d4b2b41419ef63681c900fc9d6cec586eec7e1ed479c')
15
16prepare() {
17 export GOPATH="${srcdir}/gopath"
18 go clean -modcache
19}
20
21build() {
22 export CGO_CPPFLAGS="${CPPFLAGS}"
23 export CGO_CFLAGS="${CFLAGS}"
24 export CGO_CXXFLAGS="${CXXFLAGS}"
25 export CGO_LDFLAGS="${LDFLAGS}"
26 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
27
28 cd "${pkgname}-${pkgver}/cmd/${pkgname}"
29 go build -v -o "${pkgname}" .
30}
31
32package() {
33 cd "${pkgname}-${pkgver}"
34 install -Dvm755 "cmd/${pkgname}/${pkgname}" -t "${pkgdir}/usr/bin"
35 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
36 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
37}