summaryrefslogtreecommitdiffstats
path: root/anki-official-binary-bundle/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'anki-official-binary-bundle/PKGBUILD')
-rw-r--r--anki-official-binary-bundle/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/anki-official-binary-bundle/PKGBUILD b/anki-official-binary-bundle/PKGBUILD
new file mode 100644
index 0000000..c86c8cc
--- /dev/null
+++ b/anki-official-binary-bundle/PKGBUILD
@@ -0,0 +1,36 @@
1# Maintainer: Kuklin István <kuklinistvan@zoho.com>
2# Maintainer: Aria Moradi <aria.moradi007 at gmail dot com>
3
4
5pkgname=anki-official-binary-bundle
6pkgver=2.1.65
7_pkgname="anki-$pkgver-linux-qt6"
8pkgrel=1
9epoch=
10pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
11arch=('x86_64')
12url="https://github.com/ankitects/anki"
13license=('AGPL')
14groups=()
15depends=('libxkbcommon-x11')
16makedepends=()
17optdepends=('mpv')
18provides=('anki')
19conflicts=('anki' 'anki-bin' 'anki-git')
20replaces=()
21options=()
22install=$pkgname.install
23source=("https://github.com/ankitects/anki/releases/download/${pkgver}/${_pkgname}.tar.zst"
24 "install_sh.patch")
25sha256sums=('241a96fda08c5324741f9d96318b9591c137fedfe3a0bc5fbc5868eb8233bc38'
26 '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c')
27
28prepare() {
29 cd "$srcdir/$_pkgname"
30 patch install.sh ../install_sh.patch
31}
32
33package() {
34 cd "$_pkgname"
35 PREFIX="$pkgdir/usr/" ./install.sh
36}