diff options
Diffstat (limited to 'anki-official-binary-bundle/PKGBUILD')
-rw-r--r-- | anki-official-binary-bundle/PKGBUILD | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/anki-official-binary-bundle/PKGBUILD b/anki-official-binary-bundle/PKGBUILD new file mode 100644 index 0000000..c86c8cc --- /dev/null +++ b/anki-official-binary-bundle/PKGBUILD | |||
@@ -0,0 +1,36 @@ | |||
1 | # Maintainer: Kuklin István <kuklinistvan@zoho.com> | ||
2 | # Maintainer: Aria Moradi <aria.moradi007 at gmail dot com> | ||
3 | |||
4 | |||
5 | pkgname=anki-official-binary-bundle | ||
6 | pkgver=2.1.65 | ||
7 | _pkgname="anki-$pkgver-linux-qt6" | ||
8 | pkgrel=1 | ||
9 | epoch= | ||
10 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." | ||
11 | arch=('x86_64') | ||
12 | url="https://github.com/ankitects/anki" | ||
13 | license=('AGPL') | ||
14 | groups=() | ||
15 | depends=('libxkbcommon-x11') | ||
16 | makedepends=() | ||
17 | optdepends=('mpv') | ||
18 | provides=('anki') | ||
19 | conflicts=('anki' 'anki-bin' 'anki-git') | ||
20 | replaces=() | ||
21 | options=() | ||
22 | install=$pkgname.install | ||
23 | source=("https://github.com/ankitects/anki/releases/download/${pkgver}/${_pkgname}.tar.zst" | ||
24 | "install_sh.patch") | ||
25 | sha256sums=('241a96fda08c5324741f9d96318b9591c137fedfe3a0bc5fbc5868eb8233bc38' | ||
26 | '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c') | ||
27 | |||
28 | prepare() { | ||
29 | cd "$srcdir/$_pkgname" | ||
30 | patch install.sh ../install_sh.patch | ||
31 | } | ||
32 | |||
33 | package() { | ||
34 | cd "$_pkgname" | ||
35 | PREFIX="$pkgdir/usr/" ./install.sh | ||
36 | } | ||