summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ec24cd..ee6d7b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> 3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
4pkgname=htpdate 4pkgname=htpdate
5pkgver=1.2.2 5pkgver=1.2.2
6pkgrel=2 6pkgrel=3
7pkgdesc="A client for time synchronisation" 7pkgdesc="A client for time synchronisation"
8arch=(i686 x86_64) 8arch=(i686 x86_64)
9url="http://www.vervest.org/htp/" 9url="http://www.vervest.org/htp/"
@@ -12,14 +12,15 @@ depends=('glibc')
12# TODO: In the process of adding two patches from OpenWRT, but they are rejected. 12# TODO: In the process of adding two patches from OpenWRT, but they are rejected.
13# See https://aur.archlinux.org/packages/htpdate/. 13# See https://aur.archlinux.org/packages/htpdate/.
14source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" 14source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz"
15 "htpdate.service") 15 "htpdate.service"
16 "100-pidfile.patch")
16md5sums=('aad8c33933648532ac8716c809b15be1' 17md5sums=('aad8c33933648532ac8716c809b15be1'
17 'd00fce722a88150cffb1b322e6cc8869') 18 'd00fce722a88150cffb1b322e6cc8869'
18 # "100-adjtimex.patch" 19 'f4612bb44274ed571117724a49abb3c1')
19 # "101-daemon-run-in-foreground.patch")
20 20
21build() { 21build() {
22 cd ${pkgname}-${pkgver} 22 cd ${pkgname}-${pkgver}
23 patch htpdate.c 100-pidfile.patch
23 make 24 make
24} 25}
25 26