summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f29ee6e..6839a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
1# Maintainer: Dominik Schrempf <dominik.schrempf at openmailbox dot org> 1# Maintainer: Dominik Schrempf <dominik.schrempf at gmail dot com>
2# Contributor: Jonathan Ryan <jryan at curious-computing dot com> 2# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> 3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
4pkgname=htpdate 4pkgname=htpdate
5pkgver=1.2.0 5pkgver=1.2.1
6pkgrel=2 6pkgrel=1
7pkgdesc="A client for time synchronisation" 7pkgdesc="A client for time synchronisation"
8arch=(i686 x86_64) 8arch=(i686 x86_64)
9url="http://www.vervest.org/htp/" 9url="http://www.vervest.org/htp/"
10license=(GPL2) 10license=(GPL2)
11depends=('glibc') 11depends=('glibc')
12source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" "htpdate.service") 12# TODO: In the process of adding two patches from OpenWRT, but they are rejected.
13md5sums=('9d5ca69be06edf5d535b52b5f790da4e' 13# See https://aur.archlinux.org/packages/htpdate/.
14source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz"
15 "htpdate.service")
16md5sums=('cab01ddcb62bd84154670a37a7a0c31c'
14 'ed9c9b1222e90e6ee0751f8f88772606') 17 'ed9c9b1222e90e6ee0751f8f88772606')
18 # "100-adjtimex.patch"
19 # "101-daemon-run-in-foreground.patch")
20
15build() { 21build() {
16 cd ${pkgname}-${pkgver} 22 cd ${pkgname}-${pkgver}
17 make 23 make
18} 24}
25
19package() { 26package() {
20 install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service 27 install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
21 cd ${pkgname}-${pkgver} 28 cd ${pkgname}-${pkgver}
22 install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate 29 install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate
23 install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 30 install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
24} 31}
25