summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d9171c..21398be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,26 +15,29 @@
15 15
16pkgname=popcorntime-bin 16pkgname=popcorntime-bin
17_pkgname=popcorntime 17_pkgname=popcorntime
18pkgver=0.3.10 18pkgver=0.4.1
19pkgrel=7 19pkgrel=1
20pkgdesc="Stream movies and TV shows from torrents (stable builds)" 20pkgdesc="Stream free movies and TV shows from torrents"
21arch=('x86_64') 21arch=('x86_64')
22url="https://popcorntime.app" 22url="https://popcorntime.app/"
23license=('GPL3') 23license=('GPL3')
24depends=('nss' 'ttf-font' 'libxss' 'gconf' 'gtk2' 'gtk3') 24depends=('nss' 'ttf-font' 'libxss' 'gconf' 'gtk2' 'gtk3')
25makedepends=('unzip')
25provides=('popcorntime' 'popcorn-time-ce' 'popcorntime-ci-bin' 'popcorntime-stable-bin') 26provides=('popcorntime' 'popcorn-time-ce' 'popcorntime-ci-bin' 'popcorntime-stable-bin')
26conflicts=('popcorntime') 27conflicts=('popcorntime')
27options=('!strip') 28options=('!strip')
28source=("${_pkgname}.desktop" "https://get.popcorntime.app/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") 29_zipfile="Popcorn-Time-${pkgver}-linux64.zip"
29sha512sums=('7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb' 30source=("https://get.popcorntime.app/build/$_zipfile"
30 '0fe3c1be064231134eacfb0be74266361ba5d521f0cda2848cad5357fe03d6603284e80ed3bdacdf0a012b415949b9603ff3dcf95b03693e2f7704d500ee9516') 31 "${_pkgname}.desktop" )
32sha256sums=('e167c42ffa49d5bf9f530ad998275dbcf38195bd0b10a121922d91dd528d546c'
33 '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
31 34
32package() { 35package() {
33 install -dm755 "${pkgdir}/usr/share/${_pkgname}" 36 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
34 install -dm755 "${pkgdir}/usr/bin" 37 install -dm755 "${pkgdir}/usr/bin"
35 38
36 # Link to program 39 # Link to program
37 ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" 40 ln -s "../share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
38 41
39 # Desktop file 42 # Desktop file
40 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" 43 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
@@ -43,12 +46,13 @@ package() {
43 install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" 46 install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
44 47
45 # Remove makepkg-created symlinks before copying content 48 # Remove makepkg-created symlinks before copying content
46 rm *.tar.xz *.desktop 49 rm "$_zipfile" "${_pkgname}.desktop"
47 50
48 # Move library files to /usr/lib/popcorntime 51 # Move library files to /usr/lib/popcorntime
49 install -d "${pkgdir}/usr/lib/${_pkgname}/${pkgver}" 52 install -d "${pkgdir}/usr/lib/${_pkgname}/${pkgver}"
50 mv "${srcdir}"/lib/* "${pkgdir}/usr/lib/${_pkgname}/${pkgver}" 53 mv "${srcdir}"/lib/* "${pkgdir}/usr/lib/${_pkgname}/${pkgver}"
51 rmdir "${srcdir}"/lib/ 54 rmdir "${srcdir}"/lib
55
52 install -d "${pkgdir}/etc/ld.so.conf.d" 56 install -d "${pkgdir}/etc/ld.so.conf.d"
53 echo "/usr/lib/${_pkgname}/${pkgver}" > "${pkgdir}/etc/ld.so.conf.d/${_pkgname}.conf" 57 echo "/usr/lib/${_pkgname}/${pkgver}" > "${pkgdir}/etc/ld.so.conf.d/${_pkgname}.conf"
54 58