diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 30 |
1 files changed, 13 insertions, 17 deletions
@@ -1,32 +1,28 @@ | |||
1 | # Maintainer: Dominik Schrempf <dominik.schrempf at gmail dot com> | 1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> |
2 | # Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com> | ||
2 | # Contributor: Jonathan Ryan <jryan at curious-computing dot com> | 3 | # Contributor: Jonathan Ryan <jryan at curious-computing dot com> |
3 | # Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> | 4 | # Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> |
4 | pkgname=htpdate | 5 | pkgname=htpdate |
5 | pkgver=1.2.2 | 6 | pkgver=1.2.6 |
6 | pkgrel=3 | 7 | pkgrel=1 |
7 | pkgdesc="A client for time synchronisation" | 8 | pkgdesc="A client for time synchronisation" |
8 | arch=(i686 x86_64) | 9 | arch=('i686' 'x86_64') |
9 | url="http://www.vervest.org/htp/" | 10 | url="https://github.com/angeloc/htpdate" |
10 | license=(GPL2) | 11 | license=(GPL2) |
11 | depends=('glibc') | 12 | depends=('glibc') |
12 | # TODO: In the process of adding two patches from OpenWRT, but they are rejected. | 13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" |
13 | # See https://aur.archlinux.org/packages/htpdate/. | 14 | "htpdate.service") |
14 | source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" | 15 | sha256sums=('d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909' |
15 | "htpdate.service" | 16 | '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b') |
16 | "100-pidfile.patch") | ||
17 | md5sums=('aad8c33933648532ac8716c809b15be1' | ||
18 | 'd00fce722a88150cffb1b322e6cc8869' | ||
19 | 'f4612bb44274ed571117724a49abb3c1') | ||
20 | 17 | ||
21 | build() { | 18 | build() { |
22 | cd ${pkgname}-${pkgver} | 19 | cd ${pkgname}-${pkgver} |
23 | patch htpdate.c ../100-pidfile.patch | ||
24 | make | 20 | make |
25 | } | 21 | } |
26 | 22 | ||
27 | package() { | 23 | package() { |
28 | install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service | 24 | install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service |
29 | cd ${pkgname}-${pkgver} | 25 | cd ${pkgname}-${pkgver} |
30 | install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate | 26 | install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate |
31 | install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 | 27 | install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8 |
32 | } | 28 | } |