diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 24 |
1 files changed, 15 insertions, 9 deletions
@@ -1,8 +1,8 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | 1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> |
2 | 2 | ||
3 | pkgname=ouch | 3 | pkgname=ouch |
4 | pkgver=0.3.1 | 4 | pkgver=0.4.0 |
5 | pkgrel=4 | 5 | pkgrel=1 |
6 | pkgdesc="Painless compression and decompression in the terminal" | 6 | pkgdesc="Painless compression and decompression in the terminal" |
7 | arch=('x86_64') | 7 | arch=('x86_64') |
8 | url="https://github.com/ouch-org/ouch" | 8 | url="https://github.com/ouch-org/ouch" |
@@ -10,7 +10,7 @@ license=('MIT') | |||
10 | makedepends=('cargo') | 10 | makedepends=('cargo') |
11 | conflicts=(${pkgname}-git ${pkgname}-bin) | 11 | conflicts=(${pkgname}-git ${pkgname}-bin) |
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz") | 12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz") |
13 | sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d') | 13 | sha256sums=('3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc') |
14 | 14 | ||
15 | prepare() { | 15 | prepare() { |
16 | cd "$srcdir/$pkgname-$pkgver" | 16 | cd "$srcdir/$pkgname-$pkgver" |
@@ -21,7 +21,7 @@ build() { | |||
21 | cd "$srcdir/$pkgname-$pkgver" | 21 | cd "$srcdir/$pkgname-$pkgver" |
22 | export RUSTUP_TOOLCHAIN=stable | 22 | export RUSTUP_TOOLCHAIN=stable |
23 | export CARGO_TARGET_DIR=target | 23 | export CARGO_TARGET_DIR=target |
24 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features | 24 | GEN_COMPLETIONS=1 OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features |
25 | } | 25 | } |
26 | 26 | ||
27 | check() { | 27 | check() { |
@@ -36,10 +36,16 @@ package() { | |||
36 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" | 36 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" |
37 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | 37 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" |
38 | 38 | ||
39 | cd target/release/build/ouch-*/out/completions | 39 | cd "$srcdir/$pkgname-$pkgver/artifacts" |
40 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch | ||
41 | 40 | ||
42 | install -Dm0644 ${pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${pkgname}" | 41 | # install manpages |
43 | install -Dm0644 ${pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish" | 42 | install -Dm0644 "${pkgname}.1" -t "${pkgdir}/usr/share/man/man1" |
44 | install -Dm0644 _${pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}" | 43 | install -Dm0644 "${pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1" |
44 | install -Dm0644 "${pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1" | ||
45 | install -Dm0644 "${pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1" | ||
46 | |||
47 | # install shell completions | ||
48 | install -Dm0644 "${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}" | ||
49 | install -Dm0644 "${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish" | ||
50 | install -Dm0644 "_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}" | ||
45 | } | 51 | } |