summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d00377..417d414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
2 2
3pkgname=ouch 3pkgname=ouch
4pkgver=0.3.1 4pkgver=0.3.1
5pkgrel=1 5pkgrel=2
6pkgdesc="Painless compression and decompression in the terminal" 6pkgdesc="Painless compression and decompression in the terminal"
7arch=('x86_64') 7arch=('x86_64')
8url="https://github.com/ouch-org/ouch" 8url="https://github.com/ouch-org/ouch"
9license=('MIT') 9license=('MIT')
10makedepends=('cargo') 10makedepends=('cargo')
11conflicts=(${pkgname}-git)
11source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") 12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
12sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d') 13sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d')
13 14
@@ -20,10 +21,23 @@ build() {
20 cd "$pkgname-$pkgver" 21 cd "$pkgname-$pkgver"
21 export RUSTUP_TOOLCHAIN=stable 22 export RUSTUP_TOOLCHAIN=stable
22 export CARGO_TARGET_DIR=target 23 export CARGO_TARGET_DIR=target
23 cargo build --frozen --release --all-features 24 GEN_COMPLETIONS=1 cargo build --frozen --release --all-features
25}
26
27check() {
28 cd "$pkgname-$pkgver"
29 export RUSTUP_TOOLCHAIN=stable
30 cargo test --frozen --all-features
24} 31}
25 32
26package() { 33package() {
27 cd "$pkgname-$pkgver" 34 cd "$pkgname-$pkgver"
28 install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" 35 install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
36
37 cd target/release/build/ouch-*/out/completions
38 sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch
39
40 install -Dm0644 ${pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
41 install -Dm0644 ${pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
42 install -Dm0644 _${pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
29} 43}