diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 16 |
1 files changed, 9 insertions, 7 deletions
@@ -1,17 +1,19 @@ | |||
1 | # Maintainer: mickael9 <mickael9 at gmail dot com> | 1 | # Maintainer: mickael9 <mickael9 at gmail dot com> |
2 | |||
2 | pkgname=wapiti | 3 | pkgname=wapiti |
3 | pkgver=2.3.0 | 4 | pkgver=3.0.0 |
4 | pkgrel=2 | 5 | pkgrel=1 |
5 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." | 6 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." |
6 | url='http://wapiti.sourceforge.net/' | 7 | url='http://wapiti.sourceforge.net/' |
7 | license=(GPL) | 8 | license=(GPL) |
8 | depends=(python2 python2-setuptools python2-requests python2-beautifulsoup3) | 9 | depends=(python python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks) |
9 | arch=(any) | 10 | arch=(any) |
10 | 11 | ||
11 | source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/$pkgname-$pkgver.tar.gz) | 12 | source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz") |
12 | md5sums=('dd8b0ab120518215abf9c7b22251fd8b') | 13 | sha256sums=('4708fa1d8159b0a5e606bdb26e1454e8df1d8bf6e11d9ad63c84e12e8edc8daa') |
13 | 14 | ||
14 | package() { | 15 | package() { |
15 | cd "$srcdir/${pkgname}-${pkgver}" | 16 | cd "${srcdir}/${pkgname}-${pkgver}" |
16 | python2 setup.py install --root="$pkgdir/" --optimize=1 | 17 | python setup.py install --root="${pkgdir}/" --optimize=1 |
18 | chmod 644 "${pkgdir}/usr/share/man/man1/wapiti.1" | ||
17 | } | 19 | } |