summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d2d036..fc6b61c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
1# Maintainer: mickael9 <mickael9 at gmail dot com> 1# Maintainer: mickael9 <mickael9 at gmail dot com>
2
2pkgname=wapiti 3pkgname=wapiti
3pkgver=2.3.0 4pkgver=3.0.0
4pkgrel=2 5pkgrel=1
5pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." 6pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..."
6url='http://wapiti.sourceforge.net/' 7url='http://wapiti.sourceforge.net/'
7license=(GPL) 8license=(GPL)
8depends=(python2 python2-setuptools python2-requests python2-beautifulsoup3) 9depends=(python python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks)
9arch=(any) 10arch=(any)
10 11
11source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/$pkgname-$pkgver.tar.gz) 12source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
12md5sums=('dd8b0ab120518215abf9c7b22251fd8b') 13sha256sums=('4708fa1d8159b0a5e606bdb26e1454e8df1d8bf6e11d9ad63c84e12e8edc8daa')
13 14
14package() { 15package() {
15 cd "$srcdir/${pkgname}-${pkgver}" 16 cd "${srcdir}/${pkgname}-${pkgver}"
16 python2 setup.py install --root="$pkgdir/" --optimize=1 17 python setup.py install --root="${pkgdir}/" --optimize=1
18 chmod 644 "${pkgdir}/usr/share/man/man1/wapiti.1"
17} 19}