diff options
-rw-r--r-- | .SRCINFO | 9 | ||||
-rw-r--r-- | ChangeLog | 8 | ||||
-rw-r--r-- | PKGBUILD | 29 |
3 files changed, 26 insertions, 20 deletions
@@ -1,6 +1,6 @@ | |||
1 | pkgbase = wapiti | 1 | pkgbase = wapiti |
2 | pkgdesc = Comprehensive web app vulnerability scanner written in Python | 2 | pkgdesc = Comprehensive web app vulnerability scanner written in Python |
3 | pkgver = 3.1.2 | 3 | pkgver = 3.1.3 |
4 | pkgrel = 1 | 4 | pkgrel = 1 |
5 | url = https://wapiti-scanner.github.io | 5 | url = https://wapiti-scanner.github.io |
6 | changelog = ChangeLog | 6 | changelog = ChangeLog |
@@ -18,11 +18,14 @@ pkgbase = wapiti | |||
18 | depends = python-tld | 18 | depends = python-tld |
19 | depends = python-httpx | 19 | depends = python-httpx |
20 | depends = python-aiocache | 20 | depends = python-aiocache |
21 | depends = python-aiosqlite | ||
21 | depends = python-sqlalchemy | 22 | depends = python-sqlalchemy |
23 | depends = python-loguru | ||
24 | depends = python-cryptography | ||
22 | optdepends = python-requests-kerberos: Kerberos authentication | 25 | optdepends = python-requests-kerberos: Kerberos authentication |
23 | optdepends = python-requests-ntlm: NTLM authentication | 26 | optdepends = python-requests-ntlm: NTLM authentication |
24 | options = zipman | 27 | options = zipman |
25 | source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.2/wapiti3-3.1.2.tar.gz | 28 | source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.3/wapiti3-3.1.3.tar.gz |
26 | sha256sums = d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9 | 29 | sha256sums = 83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61 |
27 | 30 | ||
28 | pkgname = wapiti | 31 | pkgname = wapiti |
@@ -1,3 +1,9 @@ | |||
1 | 09/07/2022 | ||
2 | Wapiti 3.1.3 | ||
3 | Reports: Add a new --detailed-report option that will put HTTP responses (headers and bodies) in the report. | ||
4 | Crawler: Add a new --mitm-port option that will replace the crawler with an intercepting proxy (mitmproxy) | ||
5 | Core: Dropped support of Python 3.7 | ||
6 | |||
1 | 13/05/2022 | 7 | 13/05/2022 |
2 | Wapiti 3.1.2 | 8 | Wapiti 3.1.2 |
3 | mod_http_headers: Deprecate X-XSS-Protection header | 9 | mod_http_headers: Deprecate X-XSS-Protection header |
@@ -343,7 +349,7 @@ | |||
343 | GET_XSS: only scan for XSS with HTTP GET method (no post) | 349 | GET_XSS: only scan for XSS with HTTP GET method (no post) |
344 | POST_XSS: XSS attacks using POST and not GET | 350 | POST_XSS: XSS attacks using POST and not GET |
345 | GET_ALL: every attack without POST requests | 351 | GET_ALL: every attack without POST requests |
346 | 352 | ||
347 | 12/08/2006 | 353 | 12/08/2006 |
348 | Version 1.1.3 | 354 | Version 1.1.3 |
349 | Fixed the timeout bug with chunked responses | 355 | Fixed the timeout bug with chunked responses |
@@ -1,37 +1,37 @@ | |||
1 | # Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) | 1 | # Maintainer : Yigit Sever <yigit at yigitsever dot com> |
2 | # Contributor : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) | ||
2 | # Contributor : mickael9 <mickael9 at gmail dot com> | 3 | # Contributor : mickael9 <mickael9 at gmail dot com> |
3 | 4 | ||
4 | |||
5 | pkgname=wapiti | 5 | pkgname=wapiti |
6 | 6 | pkgver=3.1.3 | |
7 | pkgver=3.1.2 | ||
8 | _name="$pkgname${pkgver:0:1}" | 7 | _name="$pkgname${pkgver:0:1}" |
9 | pkgrel=1 | 8 | pkgrel=1 |
10 | |||
11 | pkgdesc='Comprehensive web app vulnerability scanner written in Python' | 9 | pkgdesc='Comprehensive web app vulnerability scanner written in Python' |
12 | arch=('any') | 10 | arch=('any') |
13 | url="https://$pkgname-scanner.github.io" | 11 | url="https://$pkgname-scanner.github.io" |
14 | license=('GPL') | 12 | license=('GPL') |
15 | |||
16 | makedepends=('python-setuptools') | 13 | makedepends=('python-setuptools') |
17 | depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' | 14 | depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' |
18 | 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' | 15 | 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' |
19 | 'python-aiocache' 'python-sqlalchemy') | 16 | 'python-aiocache' 'python-aiosqlite' 'python-sqlalchemy' 'python-loguru' 'python-cryptography') |
20 | optdepends=('python-requests-kerberos: Kerberos authentication' | 17 | optdepends=('python-requests-kerberos: Kerberos authentication' |
21 | 'python-requests-ntlm: NTLM authentication') | 18 | 'python-requests-ntlm: NTLM authentication') |
22 | |||
23 | options=('zipman') | 19 | options=('zipman') |
24 | |||
25 | changelog=ChangeLog | 20 | changelog=ChangeLog |
26 | source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") | 21 | source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") |
27 | #source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz") | 22 | sha256sums=('83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61') |
28 | sha256sums=('d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9') | ||
29 | |||
30 | 23 | ||
31 | prepare() { rm -rf "$_name-$pkgver/tests"; } | 24 | prepare() { |
25 | rm -rf "$_name-$pkgver/tests" | ||
26 | } | ||
32 | 27 | ||
33 | build() { | 28 | build() { |
34 | cd "$_name-$pkgver" | 29 | cd "$_name-$pkgver" |
30 | sed -i '/mitmproxy==8.0.0/s/==8.0.0/>=8.0.0/' setup.py | ||
31 | sed -i '/dnspython==2.1.0/s/==2.1.0/>=2.1.0/' setup.py | ||
32 | sed -i '/cryptography==36.0.2/s/==36.0.2/>=36.0.2/' setup.py | ||
33 | sed -i '/browser-cookie3==0.11.4/s/==0.11.4/>=0.11.4/' setup.py | ||
34 | sed -i '/importlib_metadata==3.7.2/s/==3.7.2/>=3.7.2/' setup.py | ||
35 | python setup.py build | 35 | python setup.py build |
36 | } | 36 | } |
37 | 37 | ||
@@ -39,6 +39,3 @@ package() { | |||
39 | cd "$_name-$pkgver" | 39 | cd "$_name-$pkgver" |
40 | PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build | 40 | PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build |
41 | } | 41 | } |
42 | |||
43 | |||
44 | # vim: ts=2 sw=2 et ft=PKGBUILD: | ||