diff options
-rw-r--r-- | PKGBUILD | 15 | ||||
-rw-r--r-- | prefix-fix.patch | 11 |
2 files changed, 17 insertions, 9 deletions
@@ -6,7 +6,7 @@ | |||
6 | # Maintainer: Kuklin István <kuklinistvan@zoho.com> | 6 | # Maintainer: Kuklin István <kuklinistvan@zoho.com> |
7 | pkgname=anki-official-binary-bundle | 7 | pkgname=anki-official-binary-bundle |
8 | pkgver=2.1.9 | 8 | pkgver=2.1.9 |
9 | pkgrel=1 | 9 | pkgrel=2 |
10 | epoch= | 10 | epoch= |
11 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." | 11 | pkgdesc="The official binary shipped with the tested versions of the dependent libraries." |
12 | arch=('x86_64') | 12 | arch=('x86_64') |
@@ -25,14 +25,16 @@ options=() | |||
25 | install= | 25 | install= |
26 | changelog= | 26 | changelog= |
27 | topdirname="anki-$pkgver-linux-amd64" | 27 | topdirname="anki-$pkgver-linux-amd64" |
28 | source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch") | 28 | source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch" "prefix-fix.patch") |
29 | noextract=() | 29 | noextract=() |
30 | md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f') | 30 | md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f' |
31 | '5968099e737668ad7134edfd8bc6f323') | ||
31 | validpgpkeys=() | 32 | validpgpkeys=() |
32 | 33 | ||
33 | prepare() { | 34 | prepare() { |
34 | cd "$srcdir" | 35 | cd "$srcdir" |
35 | patch -p0 -i remove_xdg_cmds_from_makefile.patch | 36 | patch -p0 -i remove_xdg_cmds_from_makefile.patch |
37 | patch -p0 -i prefix-fix.patch | ||
36 | } | 38 | } |
37 | 39 | ||
38 | build() { | 40 | build() { |
@@ -40,12 +42,7 @@ build() { | |||
40 | make | 42 | make |
41 | } | 43 | } |
42 | 44 | ||
43 | # check() { | ||
44 | # cd "$topdirname" | ||
45 | # make -k check | ||
46 | # } | ||
47 | |||
48 | package() { | 45 | package() { |
49 | cd "$topdirname" | 46 | cd "$topdirname" |
50 | make PREFIX="$pkgdir/usr" install | 47 | make PREFIX="$pkgdir/usr/" install |
51 | } | 48 | } |
diff --git a/prefix-fix.patch b/prefix-fix.patch new file mode 100644 index 0000000..f462e06 --- /dev/null +++ b/prefix-fix.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- anki-2.1.9-linux-amd64/Makefile.orig 2019-03-04 19:24:16.040322000 +0100 | ||
2 | +++ anki-2.1.9-linux-amd64/Makefile 2019-03-04 19:29:45.048864131 +0100 | ||
3 | @@ -10,7 +10,7 @@ | ||
4 | mkdir -p ${PREFIX}/share/anki | ||
5 | cp -av * ${PREFIX}/share/anki/ | ||
6 | mkdir -p ${PREFIX}/bin | ||
7 | - ln -sf ${PREFIX}/share/anki/bin/anki ${PREFIX}/bin/ | ||
8 | + ln -sf /usr/share/anki/bin/anki ${PREFIX}/bin/ | ||
9 | # fix a previous packaging issue where we created this as a file | ||
10 | (test -f ${PREFIX}/share/applications && rm ${PREFIX}/share/applications)||true | ||
11 | mkdir -p ${PREFIX}/share/pixmaps | ||