diff options
-rw-r--r-- | osh/.SRCINFO | 13 | ||||
-rw-r--r-- | osh/PKGBUILD | 32 |
2 files changed, 0 insertions, 45 deletions
diff --git a/osh/.SRCINFO b/osh/.SRCINFO deleted file mode 100644 index 24ce452..0000000 --- a/osh/.SRCINFO +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | pkgbase = osh | ||
2 | pkgdesc = Oil Shell - A bash-compatible UNIX shell written in Python | ||
3 | pkgver = 0.9.6 | ||
4 | pkgrel = 1 | ||
5 | url = https://www.oilshell.org/ | ||
6 | arch = any | ||
7 | license = Apache | ||
8 | optdepends = readline: interactive features | ||
9 | options = !strip | ||
10 | source = https://www.oilshell.org/download/oil-0.9.6.tar.xz | ||
11 | sha256sums = e1c7d1cac276d36cb5f7de9307fee3be558ee4adaf349ef422322400d5c8a5c4 | ||
12 | |||
13 | pkgname = osh | ||
diff --git a/osh/PKGBUILD b/osh/PKGBUILD deleted file mode 100644 index 83b3c8a..0000000 --- a/osh/PKGBUILD +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Qontinuum <qontinuum@artixlinux.org> | ||
3 | # Contributor: timetoplatypus <timetoplatypus@protonmail.com> | ||
4 | # Contributor: andychu <andy@oilshell.org> | ||
5 | |||
6 | pkgname=osh | ||
7 | pkgver=0.9.6 | ||
8 | pkgrel=1 | ||
9 | pkgdesc="Oil Shell - A bash-compatible UNIX shell written in Python" | ||
10 | arch=('any') | ||
11 | url="https://www.oilshell.org/" | ||
12 | license=("Apache") | ||
13 | options=(!strip) | ||
14 | optdepends=("readline: interactive features") | ||
15 | source=("https://www.oilshell.org/download/oil-$pkgver.tar.xz") | ||
16 | sha256sums=('e1c7d1cac276d36cb5f7de9307fee3be558ee4adaf349ef422322400d5c8a5c4') | ||
17 | |||
18 | prepare() { | ||
19 | mkdir -p tmp | ||
20 | sed 's/TMP=${TMPDIR:-\/tmp}/TMP=..\/tmp/' -i "oil-$pkgver/configure" | ||
21 | } | ||
22 | |||
23 | build() { | ||
24 | cd "oil-$pkgver" | ||
25 | ./configure --prefix="/usr" | ||
26 | make $MAKEFLAGS | ||
27 | } | ||
28 | |||
29 | package() { | ||
30 | cd "oil-$pkgver" | ||
31 | DESTDIR="$pkgdir/" ./install | ||
32 | } | ||