summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e96002..0a6b7c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
1pkgbase = wapiti 1pkgbase = wapiti
2 pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections... 2 pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections...
3 pkgver = 3.0.0 3 pkgver = 3.0.1
4 pkgrel = 2 4 pkgrel = 1
5 url = http://wapiti.sourceforge.net/ 5 url = http://wapiti.sourceforge.net/
6 arch = any 6 arch = any
7 license = GPL 7 license = GPL
@@ -14,8 +14,8 @@ pkgbase = wapiti
14 depends = python-yaswfp 14 depends = python-yaswfp
15 depends = python-mako 15 depends = python-mako
16 depends = python-pysocks 16 depends = python-pysocks
17 source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.0/wapiti-3.0.0.tar.gz 17 source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.1/wapiti3-3.0.1.tar.gz
18 sha256sums = 4238b336773b6cb1a36a5a2f2fa0bbe413a41e13fa6f5b109dbf6bbc897e4b46 18 sha256sums = bbb8c8f572afe77319734489a6ca0b211df4b87ad294db79b8bf0bda1c5aff29
19 19
20pkgname = wapiti 20pkgname = wapiti
21 21
diff --git a/PKGBUILD b/PKGBUILD
index 4f52a0e..6004eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
1# Maintainer: mickael9 <mickael9 at gmail dot com> 1# Maintainer: mickael9 <mickael9 at gmail dot com>
2 2
3pkgname=wapiti 3pkgname=wapiti
4pkgver=3.0.0 4pkgver=3.0.1
5pkgrel=2 5pkgrel=1
6pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." 6pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..."
7url='http://wapiti.sourceforge.net/' 7url='http://wapiti.sourceforge.net/'
8license=(GPL) 8license=(GPL)
9depends=(python python-setuptools python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks) 9depends=(python python-setuptools python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks)
10arch=(any) 10arch=(any)
11 11
12source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz") 12source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}${pkgver:0:1}-${pkgver}.tar.gz")
13sha256sums=('4238b336773b6cb1a36a5a2f2fa0bbe413a41e13fa6f5b109dbf6bbc897e4b46') 13sha256sums=('bbb8c8f572afe77319734489a6ca0b211df4b87ad294db79b8bf0bda1c5aff29')
14 14
15package() { 15package() {
16 cd "${srcdir}/${pkgname}-${pkgver}" 16 cd "${srcdir}/${pkgname}${pkgver:0:1}-${pkgver}"
17 python setup.py install --root="${pkgdir}/" --optimize=1 17 python setup.py install --root="${pkgdir}/" --optimize=1
18} 18}