summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ouch-bin/.SRCINFO14
-rw-r--r--ouch-bin/PKGBUILD40
-rw-r--r--ouch/.SRCINFO14
-rw-r--r--ouch/PKGBUILD52
4 files changed, 0 insertions, 120 deletions
diff --git a/ouch-bin/.SRCINFO b/ouch-bin/.SRCINFO
deleted file mode 100644
index 395e550..0000000
--- a/ouch-bin/.SRCINFO
+++ /dev/null
@@ -1,14 +0,0 @@
1pkgbase = ouch-bin
2 pkgdesc = Painless compression and decompression in the terminal (binary release)
3 pkgver = 0.4.0
4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch
6 arch = x86_64
7 license = MIT
8 provides = ouch
9 conflicts = ouch
10 conflicts = ouch-git
11 source = ouch-0.4.0.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.0/ouch-x86_64-unknown-linux-gnu.tar.gz
12 sha256sums = 4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b
13
14pkgname = ouch-bin
diff --git a/ouch-bin/PKGBUILD b/ouch-bin/PKGBUILD
deleted file mode 100644
index 0641836..0000000
--- a/ouch-bin/PKGBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch-bin
4_pkgname=${pkgname%-bin}
5pkgver=0.4.0
6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64')
9url="https://github.com/ouch-org/ouch"
10license=('MIT')
11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/ouch-x86_64-unknown-linux-gnu.tar.gz")
14sha256sums=('4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b')
15
16package() {
17 # Binary releaes is archived in a folder with a generic name, it is not ideal
18 # (e.g. aur helpers will complain about name clashes)
19 # So we fix it
20 cd "${srcdir}"
21 mkdir "${_pkgname}-${pkgver}"
22 mv "${srcdir}/ouch-x86_64-unknown-linux-gnu/"* "${_pkgname}-${pkgver}"
23 rmdir ouch-x86_64-unknown-linux-gnu
24
25 cd "${srcdir}/${_pkgname}-${pkgver}"
26
27 install -Dm0755 -t "${pkgdir}/usr/bin" "${_pkgname}"
28 install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
29
30 # install manpages
31 install -Dm0644 "man/${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
32 install -Dm0644 "man/${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
33 install -Dm0644 "man/${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
34 install -Dm0644 "man/${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
35
36 # install shell completions
37 install -Dm0644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
38 install -Dm0644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
39 install -Dm0644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
40}
diff --git a/ouch/.SRCINFO b/ouch/.SRCINFO
deleted file mode 100644
index 9ab8a60..0000000
--- a/ouch/.SRCINFO
+++ /dev/null
@@ -1,14 +0,0 @@
1pkgbase = ouch
2 pkgdesc = Painless compression and decompression in the terminal
3 pkgver = 0.4.1
4 pkgrel = 2
5 url = https://github.com/ouch-org/ouch
6 arch = x86_64
7 license = MIT
8 makedepends = cargo
9 conflicts = ouch-git
10 conflicts = ouch-bin
11 source = ouch-0.4.1.tar.gz::https://github.com/ouch-org/ouch/archive/refs/tags/0.4.1.tar.gz
12 sha256sums = b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79
13
14pkgname = ouch
diff --git a/ouch/PKGBUILD b/ouch/PKGBUILD
deleted file mode 100644
index 349b337..0000000
--- a/ouch/PKGBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch
4pkgver=0.4.1
5pkgrel=2
6pkgdesc="Painless compression and decompression in the terminal"
7arch=('x86_64')
8url="https://github.com/ouch-org/ouch"
9license=('MIT')
10makedepends=('cargo')
11conflicts=(${pkgname}-git ${pkgname}-bin)
12source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
13sha256sums=('3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc')
14
15prepare() {
16 cd "$srcdir/$pkgname-$pkgver"
17 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
18}
19
20build() {
21 cd "$srcdir/$pkgname-$pkgver"
22 export RUSTUP_TOOLCHAIN=stable
23 export CARGO_TARGET_DIR=target
24 OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features
25}
26
27check() {
28 cd "$srcdir/$pkgname-$pkgver"
29 export RUSTUP_TOOLCHAIN=stable
30 cargo test --frozen --all-features
31}
32
33package() {
34 cd "$srcdir/$pkgname-$pkgver"
35
36 install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
37 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
38
39 cd "$srcdir/$pkgname-$pkgver/artifacts"
40
41 # install manpages
42 install -Dm0644 "${pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
43 install -Dm0644 "${pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
44 install -Dm0644 "${pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
45 install -Dm0644 "${pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
46
47 # install shell completions
48 install -Dm0644 "${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
49 install -Dm0644 "${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
50 install -Dm0644 "_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
51}
52sha256sums=('b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79')