diff options
-rw-r--r-- | .SRCINFO | 20 | ||||
-rw-r--r-- | PKGBUILD | 16 |
2 files changed, 21 insertions, 15 deletions
@@ -1,16 +1,20 @@ | |||
1 | pkgbase = wapiti | 1 | pkgbase = wapiti |
2 | pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections... | 2 | pkgdesc = A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections... |
3 | pkgver = 2.3.0 | 3 | pkgver = 3.0.0 |
4 | pkgrel = 2 | 4 | pkgrel = 1 |
5 | url = http://wapiti.sourceforge.net/ | 5 | url = http://wapiti.sourceforge.net/ |
6 | arch = any | 6 | arch = any |
7 | license = GPL | 7 | license = GPL |
8 | depends = python2 | 8 | depends = python |
9 | depends = python2-setuptools | 9 | depends = python-requests |
10 | depends = python2-requests | 10 | depends = python-beautifulsoup4 |
11 | depends = python2-beautifulsoup3 | 11 | depends = python-lxml |
12 | source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-2.3.0/wapiti-2.3.0.tar.gz | 12 | depends = python-tld |
13 | md5sums = dd8b0ab120518215abf9c7b22251fd8b | 13 | depends = python-yaswfp |
14 | depends = python-mako | ||
15 | depends = python-pysocks | ||
16 | source = http://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.0/wapiti-3.0.0.tar.gz | ||
17 | sha256sums = 4708fa1d8159b0a5e606bdb26e1454e8df1d8bf6e11d9ad63c84e12e8edc8daa | ||
14 | 18 | ||
15 | pkgname = wapiti | 19 | pkgname = wapiti |
16 | 20 | ||
@@ -1,17 +1,19 @@ | |||
1 | # Maintainer: mickael9 <mickael9 at gmail dot com> | 1 | # Maintainer: mickael9 <mickael9 at gmail dot com> |
2 | |||
2 | pkgname=wapiti | 3 | pkgname=wapiti |
3 | pkgver=2.3.0 | 4 | pkgver=3.0.0 |
4 | pkgrel=2 | 5 | pkgrel=1 |
5 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." | 6 | pkgdesc="A vulnerability scanner for web applications. It currently search vulnerabilities like XSS, SQL and XPath injections, file inclusions, command execution, LDAP injections, CRLF injections..." |
6 | url='http://wapiti.sourceforge.net/' | 7 | url='http://wapiti.sourceforge.net/' |
7 | license=(GPL) | 8 | license=(GPL) |
8 | depends=(python2 python2-setuptools python2-requests python2-beautifulsoup3) | 9 | depends=(python python-requests python-beautifulsoup4 python-lxml python-tld python-yaswfp python-mako python-pysocks) |
9 | arch=(any) | 10 | arch=(any) |
10 | 11 | ||
11 | source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/$pkgname-$pkgver.tar.gz) | 12 | source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz") |
12 | md5sums=('dd8b0ab120518215abf9c7b22251fd8b') | 13 | sha256sums=('4708fa1d8159b0a5e606bdb26e1454e8df1d8bf6e11d9ad63c84e12e8edc8daa') |
13 | 14 | ||
14 | package() { | 15 | package() { |
15 | cd "$srcdir/${pkgname}-${pkgver}" | 16 | cd "${srcdir}/${pkgname}-${pkgver}" |
16 | python2 setup.py install --root="$pkgdir/" --optimize=1 | 17 | python setup.py install --root="${pkgdir}/" --optimize=1 |
18 | chmod 644 "${pkgdir}/usr/share/man/man1/wapiti.1" | ||
17 | } | 19 | } |